# CVE-2021-21349: A Server-Side Forgery Request can be activated unmarshalling with XStream to access data streams from an arbitrary URL referencing a resource in an intranet or the local host

> Remote attackers can trigger Server-Side Request Forgery via XStream deserialization to access internal resources if security whitelists are not configured.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Mar 2021
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-activemq-2021-21349, DEBIAN-CVE-2021-21349, GHSA-f6hm-88x3-mfjv, UBUNTU-CVE-2021-21349

## What is CVE-2021-21349?

CVE-2021-21349 is a medium-severity server-side request forgery vulnerability in Apache Activemq, published on 22 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XStream is a Java library to serialize objects to XML and back again. In XStream before version 1.4.16, there is a vulnerability which may allow a remote attacker to request data from internal resources that are not publicly available only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.16.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-21349?

3 open source packages ship an affected version, including activemq and com.thoughtworks.xstream:xstream. It affects 17 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions to 5.16.0 | 5.15.14 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.16 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.16 |

Products: Apache Activemq, Apache Jmeter, Debian Debian Linux, Fedoraproject Fedora, Netapp Oncommand Insight, Oracle Banking Enterprise Default Management, Oracle Banking Platform, Oracle Banking Virtual Account Management, Oracle Business Activity Monitoring, Oracle Communications Billing and Revenue Management Elastic Charging Engine, Oracle Communications Policy Management, Oracle Communications Unified Inventory Management, Oracle Graalvm, Oracle Java Se, Oracle Retail Xstore Point of Service, Oracle Webcenter Portal, Xstream Xstream.

## How do I fix CVE-2021-21349?

Upgrade activemq to 5.15.14 or later.

## Is CVE-2021-21349 being exploited?

There is no known exploitation of CVE-2021-21349 in the wild and no public exploit code.

Public exploit code:

- XStream SSRF CVE-2021-21349 (github_poc): https://github.com/s-index/CVE-2021-21349

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21349 and fix it if it is affected.

What it is: CVE-2021-21349 is a medium-severity server-side request forgery vulnerability in Apache Activemq, published on 22 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21349 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions up to 5.16.0; fixed in 5.15.14
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.16
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21349/ (Markdown: https://insights.sbomify.com/CVE-2021-21349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21349
- OSV: https://osv.dev/vulnerability/CVE-2021-21349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21349/
Summaries are generated and may contain mistakes; the official description above is the record.
