CVE-2021-21358 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in typo3/cms-form
An authenticated backend user can inject malicious scripts via the Form Designer module, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21358?
CVE-2021-21358 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 23 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 10.4.14, 11.1.1 it has been discovered that the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. This is fixed in versions 10.4.14, 11.1.1.
Weakness: CWE-79
Which versions are affected by CVE-2021-21358?
13 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0.0 | 10.4.14 |
typo3/cms Packagist | From 10.0.0 | 10.4.14 |
typo3/cms Packagist | From 11.0.0 | 11.1.1 |
typo3/cms Packagist | From 11.0.0 | 11.1.1 |
typo3 Bitnami | From 10.2.0 | 10.4.14, 11.1.1 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.14 |
7 more packages
typo3/cms-core Packagist | From 10.0.0 | 10.4.14 |
typo3/cms-core Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-core Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-form Packagist | From 10.2.0 | 10.4.14 |
typo3/cms-form Packagist | From 10.2.0 | 10.4.14 |
typo3/cms-form Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-form Packagist | From 11.0.0 | 11.1.1 |
Products include Typo3 Typo3.
How do I fix CVE-2021-21358?
Upgrade typo3/cms to a fixed version for your release line: 10.4.14 or 11.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-21358 being exploited?
There is no known exploitation of CVE-2021-21358 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2021-21358, GHSA-x79j-wgqv-g8h2.