CVE-2021-21359 Denial of Service in Page Error Handling
Attackers can cause a denial of service in TYPO3 by triggering recursive error handling through invalid resource requests, exhausting server resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21359?
CVE-2021-21359 is a medium-severity denial of service vulnerability in Typo3 Typo3, published on 23 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 9.5.25, 10.4.14, 11.1.1 requesting invalid or non-existing resources via HTTP triggers the page error handler which again could retrieve content to be shown as error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This is fixed in versions 9.5.25, 10.4.14, 11.1.1.
Which versions are affected by CVE-2021-21359?
13 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0.0 | 10.4.14 |
typo3/cms Packagist | From 10.0.0 | 10.4.14 |
typo3/cms Packagist | From 11.0.0 | 11.1.1 |
typo3/cms Packagist | From 11.0.0 | 11.1.1 |
typo3/cms Packagist | From 9.0.0 | 9.5.25 |
typo3/cms Packagist | From 9.0.0 | 9.5.25 |
7 more packages
typo3 Bitnami | From 9.0.0 | 9.5.25, 10.4.14, 11.1.1 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.14 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.14 |
typo3/cms-core Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-core Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.25 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.25 |
Products include Typo3 Typo3.
How do I fix CVE-2021-21359?
Upgrade typo3/cms to a fixed version for your release line: 10.4.14, 11.1.1 or 9.5.25.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-21359 being exploited?
There is no known exploitation of CVE-2021-21359 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2021-21359, GHSA-4p9g-qgx9-397p.