# CVE-2021-21360: Exposure of Sensitive Information to an Unauthorized Actor in Products.GenericSetup


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jff3-mwp3-f8cw, PYSEC-2021-43

## What is CVE-2021-21360?

CVE-2021-21360 is a medium-severity vulnerability in zopefoundation Products.GenericSetup, published on 9 Mar 2021. 

### Official description

Products.GenericSetup is a mini-framework for expressing the configured state of a Zope Site as a set of filesystem artifacts. In Products.GenericSetup before version 2.1.1 there is an information disclosure vulnerability - anonymous visitors may view log and snapshot files generated by the Generic Setup Tool. The problem has been fixed in version 2.1.1. Depending on how you have installed Products.GenericSetup, you should change the buildout version pin to 2.1.1 and re-run the buildout, or if you used pip simply do pip install `"Products.GenericSetup>=2.1.1"`.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-21360?

3 open source packages ship an affected version, including Products.GenericSetup and products-genericsetup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Products.GenericSetup` | PyPI | All versions | 2.1.1 |
| `products-genericsetup` | PyPI | All versions | 2.1.1 |
| `products-genericsetup` | PyPI | All versions | 2.1.1 |

Products: Zope Products.genericsetup.

## How do I fix CVE-2021-21360?

Upgrade Products.GenericSetup to 2.1.1 or later.

## Is CVE-2021-21360 being exploited?

There is no known exploitation of CVE-2021-21360 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21360 and fix it if it is affected.

What it is: CVE-2021-21360 is a medium-severity vulnerability in zopefoundation Products.GenericSetup, published on 9 Mar 2021. 
Exploitation: There is no known exploitation of CVE-2021-21360 in the wild and no public exploit code.

Affected packages and fixed versions:
- Products.GenericSetup (PyPI): affected all versions; fixed in 2.1.1
- products-genericsetup (PyPI): affected all versions; fixed in 2.1.1
- products-genericsetup (PyPI): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21360/ (Markdown: https://insights.sbomify.com/CVE-2021-21360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21360
- OSV: https://osv.dev/vulnerability/CVE-2021-21360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21360/
Summaries are generated and may contain mistakes; the official description above is the record.
