# CVE-2021-21361: Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin

> The Gradle Vagrant plugin logs system environment variables, potentially exposing sensitive credentials in public CI/CD logs.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jpcm-4485-69p7

## What is CVE-2021-21361?

CVE-2021-21361 is a medium-severity vulnerability in JLLeitschuh security-research, published on 9 Mar 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. This is fixed in version 3.0.0.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2021-21361?

2 open source packages ship an affected version, including com.bmuschko:gradle-vagrant-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.bmuschko:gradle-vagrant-plugin` | Maven | From 0.6 | 3.0.0 |
| `com.bmuschko:gradle-vagrant-plugin` | Maven | From 0.6 | 3.0.0 |

Products: Vagrant Project Vagrant.

## How do I fix CVE-2021-21361?

Upgrade com.bmuschko:gradle-vagrant-plugin to 3.0.0 or later.

## Is CVE-2021-21361 being exploited?

There is no known exploitation of CVE-2021-21361 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21361 and fix it if it is affected.

What it is: CVE-2021-21361 is a medium-severity vulnerability in JLLeitschuh security-research, published on 9 Mar 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21361 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.bmuschko:gradle-vagrant-plugin (Maven): affected from 0.6; fixed in 3.0.0
- com.bmuschko:gradle-vagrant-plugin (Maven): affected from 0.6; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21361/ (Markdown: https://insights.sbomify.com/CVE-2021-21361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21361
- OSV: https://osv.dev/vulnerability/CVE-2021-21361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21361/
Summaries are generated and may contain mistakes; the official description above is the record.
