# CVE-2021-21364: Generated Code Contains Local Information Disclosure Vulnerability

> Local attackers can read generated code files due to insecure default permissions in swagger-codegen, exposing sensitive information.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hpv8-9rq5-hq7w

## What is CVE-2021-21364?

CVE-2021-21364 is a medium-severity vulnerability in swagger-api swagger-codegen, published on 11 Mar 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

swagger-codegen is an open-source project which contains a template-driven engine to generate documentation, API clients and server stubs in different languages by parsing your OpenAPI / Swagger definition. In swagger-codegen before version 2.4.19, on Unix-Like systems, the system temporary directory is shared between all local users. When files/directories are created, the default `umask` settings for the process are respected. As a result, by default, most processes/apis will create files/directories with the permissions `-rw-r--r--` and `drwxr-xr-x` respectively, unless an API that explicitly sets safe file permissions is used. Because this vulnerability impacts generated code, the generated code will remain vulnerable until fixed manually! This vulnerability is fixed in version 2.4.19. Note this is a distinct vulnerability from CVE-2021-21363.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-378 (Creation of Temporary File With Insecure Permissions), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-21364?

2 open source packages ship an affected version, including io.swagger:swagger-codegen. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.swagger:swagger-codegen` | Maven | All versions | 2.4.19 |
| `io.swagger:swagger-codegen` | Maven | All versions | 2.4.19 |

Products: Smartbear Swagger-Codegen.

## How do I fix CVE-2021-21364?

Upgrade io.swagger:swagger-codegen to 2.4.19 or later.

## Is CVE-2021-21364 being exploited?

There is no known exploitation of CVE-2021-21364 in the wild and no public exploit code.

## Other vulnerabilities in swagger-api swagger-codegen

- [CVE-2021-21363](https://insights.sbomify.com/CVE-2021-21363/): Generator Web Application: Local Privilege Escalation Vulnerability via System Temp Directory (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21364 and fix it if it is affected.

What it is: CVE-2021-21364 is a medium-severity vulnerability in swagger-api swagger-codegen, published on 11 Mar 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21364 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.swagger:swagger-codegen (Maven): affected all versions; fixed in 2.4.19
- io.swagger:swagger-codegen (Maven): affected all versions; fixed in 2.4.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21364/ (Markdown: https://insights.sbomify.com/CVE-2021-21364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21364
- OSV: https://osv.dev/vulnerability/CVE-2021-21364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21364/
Summaries are generated and may contain mistakes; the official description above is the record.
