# CVE-2021-21366: Misinterpretation of malicious XML input

> Attackers can exploit XML parsing flaws in xmldom to cause unexpected syntactic changes, potentially leading to code execution or data exposure.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-21366, GHSA-h6q6-9hqw-rwfv, UBUNTU-CVE-2021-21366

## What is CVE-2021-21366?

CVE-2021-21366 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents. This may lead to unexpected syntactic changes during XML processing in some downstream applications. This is fixed in version 0.5.0. As a workaround downstream applications can validate the input and reject the maliciously crafted documents.

Weakness: CWE-436 (Interpretation Conflict), CWE-115 (Misinterpretation of Input)

## Which versions are affected by CVE-2021-21366?

2 open source packages ship an affected version, including xmldom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xmldom` | npm | All versions | 0.5.0 |
| `xmldom` | npm | All versions | 0.5.0 |

Products: Debian Debian Linux, Xmldom Project Xmldom.

## How do I fix CVE-2021-21366?

Upgrade xmldom to 0.5.0 or later.

## Is CVE-2021-21366 being exploited?

There is no known exploitation of CVE-2021-21366 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21366 and fix it if it is affected.

What it is: CVE-2021-21366 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21366 in the wild and no public exploit code.

Affected packages and fixed versions:
- xmldom (npm): affected all versions; fixed in 0.5.0
- xmldom (npm): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21366/ (Markdown: https://insights.sbomify.com/CVE-2021-21366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21366
- OSV: https://osv.dev/vulnerability/CVE-2021-21366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21366/
Summaries are generated and may contain mistakes; the official description above is the record.
