# CVE-2021-21368: Prototype poisoning

> Attackers can craft MessagePack data to poison object prototypes, causing type confusion, unexpected exceptions, or potential code execution in applications using msgpack5.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gmjw-49p4-pcfm

## What is CVE-2021-21368?

CVE-2021-21368 is a medium-severity unsafe deserialization vulnerability in mcollina msgpack5, published on 12 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

msgpack5 is a msgpack v5 implementation for node.js and the browser. In msgpack5 before versions 3.6.1, 4.5.1, and 5.2.1 there is a "Prototype Poisoning" vulnerability. When msgpack5 decodes a map containing a key "__proto__", it assigns the decoded value to __proto__. Object.prototype.__proto__ is an accessor property for the receiver's prototype. If the value corresponding to the key __proto__ decodes to an object or null, msgpack5 sets the decoded object's prototype to that value. An attacker who can submit crafted MessagePack data to a service can use this to produce values that appear to be of other types; may have unexpected prototype properties and methods (for example length, numeric properties, and push et al if __proto__'s value decodes to an Array); and/or may throw unexpected exceptions when used (for example if the __proto__ value decodes to a Map or Date). Other unexpected behavior might be produced for other types. There is no effect on the global prototype. This "prototype poisoning" is sort of a very limited inversion of a prototype pollution attack. Only the decoded value's prototype is affected, and it can only be set to msgpack5 values (though if the victim makes use of custom codecs, anything could be a msgpack5 value). We have not found a way to escalate this to true prototype pollution (absent other bugs in the consumer's code). This has been fixed in msgpack5 version 3.6.1, 4.5.1, and 5.2.1. See the referenced GitHub Security Advisory for an example and more details.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2021-21368?

6 open source packages ship an affected version, including msgpack5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `msgpack5` | npm | All versions | 3.6.1 |
| `msgpack5` | npm | All versions | 3.6.1 |
| `msgpack5` | npm | From 4.0.0 | 4.5.1 |
| `msgpack5` | npm | From 4.0.0 | 4.5.1 |
| `msgpack5` | npm | From 5.0.0 | 5.2.1 |
| `msgpack5` | npm | From 5.0.0 | 5.2.1 |

Products: Msgpack5 Project Msgpack5.

## How do I fix CVE-2021-21368?

Upgrade msgpack5 to a fixed version for your release line: 3.6.1, 4.5.1 or 5.2.1.

## Is CVE-2021-21368 being exploited?

There is no known exploitation of CVE-2021-21368 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21368 and fix it if it is affected.

What it is: CVE-2021-21368 is a medium-severity unsafe deserialization vulnerability in mcollina msgpack5, published on 12 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21368 in the wild and no public exploit code.

Affected packages and fixed versions:
- msgpack5 (npm): affected all versions; fixed in 3.6.1
- msgpack5 (npm): affected all versions; fixed in 3.6.1
- msgpack5 (npm): affected from 4.0.0; fixed in 4.5.1
- msgpack5 (npm): affected from 4.0.0; fixed in 4.5.1
- msgpack5 (npm): affected from 5.0.0; fixed in 5.2.1
- msgpack5 (npm): affected from 5.0.0; fixed in 5.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21368/ (Markdown: https://insights.sbomify.com/CVE-2021-21368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21368
- OSV: https://osv.dev/vulnerability/CVE-2021-21368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21368/
Summaries are generated and may contain mistakes; the official description above is the record.
