# CVE-2021-21378: JWT authentication bypass with unknown issuer token

> Attackers can bypass JWT authentication in Envoy by using an unknown issuer token when specific filter configurations are enabled.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-envoy-2021-21378, GHSA-4996-m8hf-hj27

## What is CVE-2021-21378?

CVE-2021-21378 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 11 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a cloud-native high-performance edge/middle/service proxy. In Envoy version 1.17.0 an attacker can bypass authentication by presenting a JWT token with an issuer that is not in the provider list when Envoy's JWT Authentication filter is configured with the `allow_missing` requirement under `requires_any` due to a mistake in implementation. Envoy's JWT Authentication filter can be configured with the `allow_missing` requirement that will be satisfied if JWT is missing (JwtMissed error) and fail if JWT is presented or invalid. Due to a mistake in implementation, a JwtUnknownIssuer error was mistakenly converted to JwtMissed when `requires_any` was configured. So if `allow_missing` was configured under `requires_any`, an attacker can bypass authentication by presenting a JWT token with an issuer that is not in the provider list. Integrity may be impacted depending on configuration if the JWT token is used to protect against writes or modifications. This regression was introduced on 2020/11/12 in PR 13839 which fixed handling `allow_missing` under RequiresAny in a JwtRequirement (see issue 13458). The AnyVerifier aggregates the children verifiers' results into a final status where JwtMissing is the default error. However, a JwtUnknownIssuer was mistakenly treated the same as a JwtMissing error and the resulting final aggregation was the default JwtMissing. As a result, `allow_missing` would allow a JWT token with an unknown issuer status. This is fixed in version 1.17.1 by PR 15194. The fix works by preferring JwtUnknownIssuer over a JwtMissing error, fixing the accidental conversion and bypass with `allow_missing`. A user could detect whether a bypass occurred if they have Envoy logs enabled with debug verbosity. Users can enable component level debug logs for JWT. The JWT filter logs will indicate that there is a request with a JWT token and a failure that the JWT token is missing.

Weakness: CWE-303 (Incorrect Implementation of Authentication Algorithm), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-21378?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | From 1.17.0 | 1.17.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2021-21378?

Upgrade envoy to 1.17.1 or later.

## Is CVE-2021-21378 being exploited?

There is no known exploitation of CVE-2021-21378 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21378 and fix it if it is affected.

What it is: CVE-2021-21378 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 11 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21378 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected from 1.17.0; fixed in 1.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21378/ (Markdown: https://insights.sbomify.com/CVE-2021-21378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21378
- OSV: https://osv.dev/vulnerability/CVE-2021-21378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21378/
Summaries are generated and may contain mistakes; the official description above is the record.
