# CVE-2021-21379: It's possible to execute anything with the rights of the author of a macro which uses the {{wikimacrocontent}} macro

> Attackers can execute arbitrary code with elevated privileges by injecting scripts into wiki macros that run with the author's rights.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v662-xpcc-9xf6

## What is CVE-2021-21379?

CVE-2021-21379 is a high-severity vulnerability in Xwiki Xwiki, published on 12 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions of XWiki Platform, the `{{wikimacrocontent}}` executes the content with the rights of the wiki macro author instead of the caller of that wiki macro. This makes possible to inject scripts through it and they will be executed with the rights of the wiki macro (very often a user which has Programming rights). Fortunately, no such macro exists by default in XWiki Standard but one could have been created or installed with an extension. This vulnerability has been patched in versions XWiki 12.6.3, 11.10.11 and 12.8-rc-1. There is no easy workaround other than disabling the affected macros. Inserting content in a safe way or knowing what is the user who called the wiki macro is not easy.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2021-21379?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rendering-wikimacro-store. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 11.4 | 11.10.11 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 11.4 | 11.10.11 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.0 | 12.6.3 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.0 | 12.6.3 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.7 | 12.8 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.7 | 12.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2021-21379?

Upgrade org.xwiki.platform:xwiki-platform-rendering-wikimacro-store to a fixed version for your release line: 11.10.11, 12.6.3 or 12.8.

## Is CVE-2021-21379 being exploited?

There is no known exploitation of CVE-2021-21379 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21379 and fix it if it is affected.

What it is: CVE-2021-21379 is a high-severity vulnerability in Xwiki Xwiki, published on 12 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21379 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 11.4; fixed in 11.10.11
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 11.4; fixed in 11.10.11
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.0; fixed in 12.6.3
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.0; fixed in 12.6.3
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.7; fixed in 12.8
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.7; fixed in 12.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21379/ (Markdown: https://insights.sbomify.com/CVE-2021-21379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21379
- OSV: https://osv.dev/vulnerability/CVE-2021-21379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21379/
Summaries are generated and may contain mistakes; the official description above is the record.
