{"answers":{"affected":"3 open source packages ship an affected version, including apkleaks and APKLeaks. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21386 in the wild and no public exploit code.","fix":"Upgrade apkleaks to 2.0.4 or later.","what":"CVE-2021-21386 is a critical command injection vulnerability in dwisiswant0 apkleaks, published on 24 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21386 and fix it if it is affected.\n\nWhat it is: CVE-2021-21386 is a critical command injection vulnerability in dwisiswant0 apkleaks, published on 24 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21386 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apkleaks (PyPI): affected all versions; fixed in 2.0.4\n- apkleaks (PyPI): affected all versions; fixed in 2.0.4\n- APKLeaks (PyPI): affected all versions; fixed in 2.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21386/ (Markdown: https://insights.sbomify.com/CVE-2021-21386/index.md)","id":"CVE-2021-21386","markdown":"https://insights.sbomify.com/CVE-2021-21386/index.md","name":"CVE-2021-21386","record":{"aliases":["GHSA-8434-v7xw-8m9x","PYSEC-2026-281"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"APK scanning tool","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands via malicious package names in APK manifests, affecting APKLeaks users.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apkleaks","vendor":"apkleaks_project"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"APKLeaks is an open-source project for scanning APK file for URIs, endpoints \u0026 secrets. APKLeaks prior to v2.0.3 allows remote attackers to execute arbitrary OS commands via package name inside application manifest. An attacker could include arguments that allow unintended commands or code to be executed, allow sensitive data to be read or modified or could cause other unintended behavior through malicious package name. The problem is fixed in version v2.0.6-dev and above.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Argument Delimiters in a Decompiling Package Process","id":"CVE-2021-21386","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Partial secret key disclosure, improper safety number calculation, \u0026 inadequate encryption strength","id":"CVE-2021-21387"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.4"],"introduced":["0"],"last_affected":[],"package":"APKLeaks","purl":null,"source":"GHSA-8434-v7xw-8m9x"},{"ecosystem":"PyPI","fixed":["2.0.4"],"introduced":["0"],"last_affected":[],"package":"apkleaks","purl":"pkg:pypi/apkleaks","source":"GHSA-8434-v7xw-8m9x"},{"ecosystem":"PyPI","fixed":["2.0.4"],"introduced":["0"],"last_affected":[],"package":"apkleaks","purl":"pkg:pypi/apkleaks","source":"PYSEC-2026-281"}],"prev":{"headline":"Disabled hostname verification and accepting self-signed certificates","id":"CVE-2021-21385"},"products":["apkleaks"],"published":"2021-03-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["dwisiswant0"]},"summary":"Remote attackers can execute arbitrary OS commands via malicious package names in APK manifests, affecting APKLeaks users.","url":"https://insights.sbomify.com/CVE-2021-21386/"}