# CVE-2021-21386: Improper Neutralization of Argument Delimiters in a Decompiling Package Process

> Remote attackers can execute arbitrary OS commands via malicious package names in APK manifests, affecting APKLeaks users.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8434-v7xw-8m9x, PYSEC-2026-281

## What is CVE-2021-21386?

CVE-2021-21386 is a critical command injection vulnerability in dwisiswant0 apkleaks, published on 24 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

APKLeaks is an open-source project for scanning APK file for URIs, endpoints & secrets. APKLeaks prior to v2.0.3 allows remote attackers to execute arbitrary OS commands via package name inside application manifest. An attacker could include arguments that allow unintended commands or code to be executed, allow sensitive data to be read or modified or could cause other unintended behavior through malicious package name. The problem is fixed in version v2.0.6-dev and above.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-21386?

3 open source packages ship an affected version, including apkleaks and APKLeaks. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apkleaks` | PyPI | All versions | 2.0.4 |
| `apkleaks` | PyPI | All versions | 2.0.4 |
| `APKLeaks` | PyPI | All versions | 2.0.4 |

Products: Apkleaks Project Apkleaks.

## How do I fix CVE-2021-21386?

Upgrade apkleaks to 2.0.4 or later.

## Is CVE-2021-21386 being exploited?

There is no known exploitation of CVE-2021-21386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21386 and fix it if it is affected.

What it is: CVE-2021-21386 is a critical command injection vulnerability in dwisiswant0 apkleaks, published on 24 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21386 in the wild and no public exploit code.

Affected packages and fixed versions:
- apkleaks (PyPI): affected all versions; fixed in 2.0.4
- apkleaks (PyPI): affected all versions; fixed in 2.0.4
- APKLeaks (PyPI): affected all versions; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21386/ (Markdown: https://insights.sbomify.com/CVE-2021-21386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21386
- OSV: https://osv.dev/vulnerability/CVE-2021-21386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21386/
Summaries are generated and may contain mistakes; the official description above is the record.
