{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21387 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-21387 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-21387 is a high-severity vulnerability in parabirb wrongthink, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21387 and fix it if it is affected.\n\nWhat it is: CVE-2021-21387 is a high-severity vulnerability in parabirb wrongthink, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21387 in the wild and no public exploit code.\n\nAffected product: parabirb wrongthink. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21387/ (Markdown: https://insights.sbomify.com/CVE-2021-21387/index.md)","id":"CVE-2021-21387","markdown":"https://insights.sbomify.com/CVE-2021-21387/index.md","name":"CVE-2021-21387","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"P2P encrypted messenger","requires_auth":"none","summary":"Attackers can exploit weak encryption and key disclosure flaws in the wrongthink messenger to compromise communication security.","user_interaction":"required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wrongthink","vendor":"wrongthink"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-358","name":"Improperly Implemented Security Check for Standard"},{"id":"CWE-326","name":"Inadequate Encryption Strength"},{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"}],"description":"Wrongthink peer-to-peer, end-to-end encrypted messenger with PeerJS and Axolotl ratchet. In wrongthink from version 2.0.0 and before 2.3.0 there was a set of vulnerabilities causing inadequate encryption strength. Part of the secret identity key was disclosed by the fingerprint used for connection. Additionally, the safety number was improperly calculated. It was computed using part of one of the public identity keys instead of being derived from both public identity keys. This caused issues in computing safety numbers which would potentially be exploitable in the real world. Additionally there was inadequate encryption strength due to use of 1024-bit DSA keys. These issues are all fixed in version 2.3.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Partial secret key disclosure, improper safety number calculation, \u0026 inadequate encryption strength","id":"CVE-2021-21387","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2021"},"n_packages":0,"n_references":1,"next":{"headline":"Command Injection Vulnerability in systeminformation","id":"CVE-2021-21388"},"packages":[],"prev":{"headline":"Improper Neutralization of Argument Delimiters in a Decompiling Package Process","id":"CVE-2021-21386"},"products":["wrongthink"],"published":"2021-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["parabirb"]},"summary":"Attackers can exploit weak encryption and key disclosure flaws in the wrongthink messenger to compromise communication security.","url":"https://insights.sbomify.com/CVE-2021-21387/"}