# CVE-2021-21387: Partial secret key disclosure, improper safety number calculation, & inadequate encryption strength

> Attackers can exploit weak encryption and key disclosure flaws in the wrongthink messenger to compromise communication security.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Mar 2021
- **Updated:** 3 Aug 2024

## What is CVE-2021-21387?

CVE-2021-21387 is a high-severity vulnerability in parabirb wrongthink, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Wrongthink peer-to-peer, end-to-end encrypted messenger with PeerJS and Axolotl ratchet. In wrongthink from version 2.0.0 and before 2.3.0 there was a set of vulnerabilities causing inadequate encryption strength. Part of the secret identity key was disclosed by the fingerprint used for connection. Additionally, the safety number was improperly calculated. It was computed using part of one of the public identity keys instead of being derived from both public identity keys. This caused issues in computing safety numbers which would potentially be exploitable in the real world. Additionally there was inadequate encryption strength due to use of 1024-bit DSA keys. These issues are all fixed in version 2.3.0.

Weakness: CWE-358 (Improperly Implemented Security Check for Standard), CWE-326 (Inadequate Encryption Strength), CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2021-21387?

It affects 1 product.


Products: Wrongthink Wrongthink.

## How do I fix CVE-2021-21387?

No fix has been published for CVE-2021-21387 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-21387 being exploited?

There is no known exploitation of CVE-2021-21387 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21387 and fix it if it is affected.

What it is: CVE-2021-21387 is a high-severity vulnerability in parabirb wrongthink, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21387 in the wild and no public exploit code.

Affected product: parabirb wrongthink. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21387/ (Markdown: https://insights.sbomify.com/CVE-2021-21387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21387
- OSV: https://osv.dev/vulnerability/CVE-2021-21387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21387/
Summaries are generated and may contain mistakes; the official description above is the record.
