CVE-2021-21389 BuddyPress privilege escalation via REST API

High 8.1 Published Updated

A regular user can gain administrator rights by exploiting the REST API members endpoint in the BuddyPress WordPress plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-21389?

CVE-2021-21389 is a high-severity vulnerability in BuddyPress, published on 26 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Weakness: CWE-863

Which versions are affected by CVE-2021-21389?

2 open source packages ship an affected version, including buddypress/buddypress. It affects 1 product.

PackageAffectedFixed in
buddypress/buddypress PackagistFrom 5.0.07.2.1
buddypress/buddypress PackagistFrom 5.0.07.2.1

Products include Buddypress Buddypress.

How do I fix CVE-2021-21389?

Upgrade buddypress/buddypress to 7.2.1 or later.

Is CVE-2021-21389 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21389 exists.

Public exploit code: 1 Nuclei template and 2 proofs of concept on GitHub.

Sources

Also known as GHSA-m6j4-8r7p-wpp3.

Is CVE-2021-21389 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free