{"answers":{"affected":"2 open source packages ship an affected version, including buddypress/buddypress. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21389 exists.","fix":"Upgrade buddypress/buddypress to 7.2.1 or later.","what":"CVE-2021-21389 is a high-severity vulnerability in BuddyPress, published on 26 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21389 and fix it if it is affected.\n\nWhat it is: CVE-2021-21389 is a high-severity vulnerability in BuddyPress, published on 26 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21389 exists.\n\nAffected packages and fixed versions:\n- buddypress/buddypress (Packagist): affected from 5.0.0; fixed in 7.2.1\n- buddypress/buddypress (Packagist): affected from 5.0.0; fixed in 7.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21389/ (Markdown: https://insights.sbomify.com/CVE-2021-21389/index.md)","id":"CVE-2021-21389","markdown":"https://insights.sbomify.com/CVE-2021-21389/index.md","name":"CVE-2021-21389","record":{"aliases":["GHSA-m6j4-8r7p-wpp3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"BuddyPress plugin","requires_auth":"low_privilege","summary":"A regular user can gain administrator rights by exploiting the REST API members endpoint in the BuddyPress WordPress plugin.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"buddypress","vendor":"buddypress"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2021-05-31","github_poc":2,"max_poc_stars":19,"metasploit":0,"nuclei":1,"refs":[{"date":"2021-05-31T14:12:26Z","kind":"github_poc","ref":"https://github.com/HoangKien1020/CVE-2021-21389","stars":19,"title":"BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue."},{"date":"2024-12-09T20:44:30Z","kind":"github_poc","ref":"https://github.com/mynameSumin/CVE-2021-21389","stars":0,"title":"경희대 졸업프로젝트"},{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-21389.yaml","stars":null,"title":"BuddyPress REST API  \u003c7.2.1 - Privilege Escalation/Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"BuddyPress privilege escalation via REST API","id":"CVE-2021-21389","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"privilege_escalation","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"MITM modification of request bodies in MinIO","id":"CVE-2021-21390"},"packages":[{"ecosystem":"Packagist","fixed":["7.2.1"],"introduced":["5.0.0"],"last_affected":[],"package":"buddypress/buddypress","purl":null,"source":"GHSA-m6j4-8r7p-wpp3"},{"ecosystem":"Packagist","fixed":["7.2.1"],"introduced":["5.0.0"],"last_affected":[],"package":"buddypress/buddypress","purl":"pkg:composer/buddypress/buddypress","source":"GHSA-m6j4-8r7p-wpp3"}],"prev":{"headline":"Command Injection Vulnerability in systeminformation","id":"CVE-2021-21388"},"products":["BuddyPress"],"published":"2021-03-26","related":[{"cvss_score":8.1,"headline":"BuddyPress \u003c= 14.1.0 - Authenticated (Subscriber+) Directory Traversal","id":"CVE-2024-10011","kev_date_added":null,"published":"2024-10-25"},{"cvss_score":8,"headline":"Private data exposure via REST API in BuddyPress","id":"CVE-2020-5244","kev_date_added":null,"published":"2020-02-24"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2012-2109","kev_date_added":null,"published":"2012-09-04"},{"cvss_score":7.1,"headline":"WordPress Mass Messaging in BuddyPress Plugin \u003c= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability","id":"CVE-2025-23798","kev_date_added":null,"published":"2025-01-22"},{"cvss_score":6.5,"headline":"WordPress BuddyPress Plugin \u003c= 11.3.1 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-50880","kev_date_added":null,"published":"2023-12-29"},{"cvss_score":6.5,"headline":"Missing authorization in n/a","id":"CVE-2014-1889","kev_date_added":null,"published":"2018-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["buddypress"]},"summary":"A regular user can gain administrator rights by exploiting the REST API members endpoint in the BuddyPress WordPress plugin.","url":"https://insights.sbomify.com/CVE-2021-21389/"}