# CVE-2021-21392: Open redirect via transitional IPv6 addresses on dual-stack networks

> Attackers can force the Matrix homeserver to make requests to internal infrastructure on dual-stack networks via transitional IPv6 addresses.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5wrh-4jwv-5w78, PYSEC-2021-25, UBUNTU-CVE-2021-21392

## What is CVE-2021-21392?

CVE-2021-21392 is a medium-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 12 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.28.0 requests to user provided domains were not restricted to external IP addresses when transitional IPv6 addresses were used. Outbound requests to federation, identity servers, when calculating the key validity for third-party invite events, sending push notifications, and generating URL previews are affected. This could cause Synapse to make requests to internal infrastructure on dual-stack networks. See referenced GitHub security advisory for details and workarounds.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-21392?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.28.0 |
| `matrix-synapse` | PyPI | All versions | 1.28.0rc1 |
| `matrix-synapse` | PyPI | All versions | 1.28.0rc1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2021-21392?

Upgrade matrix-synapse to a fixed version for your release line: 1.28.0 or 1.28.0rc1.

## Is CVE-2021-21392 being exploited?

There is no known exploitation of CVE-2021-21392 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21392 and fix it if it is affected.

What it is: CVE-2021-21392 is a medium-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 12 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21392 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.28.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.28.0rc1
- matrix-synapse (PyPI): affected all versions; fixed in 1.28.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21392/ (Markdown: https://insights.sbomify.com/CVE-2021-21392/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21392
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21392
- OSV: https://osv.dev/vulnerability/CVE-2021-21392

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21392/
Summaries are generated and may contain mistakes; the official description above is the record.
