# CVE-2021-21393: Denial of service (via resource exhaustion) due to improper input validation on groups/communities endpoints

> Attackers can cause resource exhaustion via improper input validation on groups endpoints, requiring the groups feature to be enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jrh7-mhhx-6h88, PYSEC-2021-26, UBUNTU-CVE-2021-21393

## What is CVE-2021-21393?

CVE-2021-21393 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.28.0 Synapse is missing input validation of some parameters on the endpoints used to confirm third-party identifiers could cause excessive use of disk space and memory leading to resource exhaustion. Note that the groups feature is not part of the Matrix specification and the chosen maximum lengths are arbitrary. Not all clients might abide by them. Refer to referenced GitHub security advisory for additional details including workarounds.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-21393?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.28.0 |
| `matrix-synapse` | PyPI | All versions | 1.28.0 |
| `matrix-synapse` | PyPI | All versions | 1.28.0 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2021-21393?

Upgrade matrix-synapse to 1.28.0 or later.

## Is CVE-2021-21393 being exploited?

There is no known exploitation of CVE-2021-21393 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21393 and fix it if it is affected.

What it is: CVE-2021-21393 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21393 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.28.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.28.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21393/ (Markdown: https://insights.sbomify.com/CVE-2021-21393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21393
- OSV: https://osv.dev/vulnerability/CVE-2021-21393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21393/
Summaries are generated and may contain mistakes; the official description above is the record.
