# CVE-2021-21395: Magneto-lts vulnerable to Cross-Site Request Forgery

> Attackers can force password resets via CSRF, potentially taking over user accounts in Magneto LTS.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-r3c9-9j5q-pwv4

## What is CVE-2021-21395?

CVE-2021-21395 is a medium-severity vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Magneto LTS (Long Term Support) is a community developed alternative to the Magento CE official releases. Versions prior to 19.4.22 and 20.0.19 are vulnerable to Cross-Site Request Forgery. The password reset form is vulnerable to CSRF between the time the reset password link is clicked and user submits new password. This issue is patched in versions 19.4.22 and 20.0.19. There are no workarounds.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-21395?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 19.4.22 |
| `openmage/magento-lts` | Packagist | All versions | 19.4.22 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.19 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.19 |

Products: Openmage Magento.

## How do I fix CVE-2021-21395?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.

## Is CVE-2021-21395 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21395 exists.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21395 and fix it if it is affected.

What it is: CVE-2021-21395 is a medium-severity vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21395 exists.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.22
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.22
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.19
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21395/ (Markdown: https://insights.sbomify.com/CVE-2021-21395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21395
- OSV: https://osv.dev/vulnerability/CVE-2021-21395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21395/
Summaries are generated and may contain mistakes; the official description above is the record.
