{"answers":{"affected":"2 open source packages ship an affected version, including github.com/kongchuanhujiao/server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21403 in the wild and no public exploit code.","fix":"Upgrade github.com/kongchuanhujiao/server to 1.3.21 or later.","what":"CVE-2021-21403 is a high-severity authentication bypass vulnerability in kongchuanhujiao server, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21403 and fix it if it is affected.\n\nWhat it is: CVE-2021-21403 is a high-severity authentication bypass vulnerability in kongchuanhujiao server, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21403 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/kongchuanhujiao/server (Go): affected all versions; fixed in 1.3.21\n- github.com/kongchuanhujiao/server (Go): affected all versions; fixed in 1.3.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21403/ (Markdown: https://insights.sbomify.com/CVE-2021-21403/index.md)","id":"CVE-2021-21403","markdown":"https://insights.sbomify.com/CVE-2021-21403/index.md","name":"CVE-2021-21403","record":{"aliases":["GHSA-8wrg-m8vm-5fvj"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Go server application","requires_auth":"none","summary":"An authentication bypass vulnerability allows attackers to access the server without valid credentials, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kongchuanhujiao","vendor":"kongchuanhujiao_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-305","name":"Authentication Bypass by Primary Weakness"}],"description":"In github.com/kongchuanhujiao/server before version 1.3.21 there is an authentication Bypass by Primary Weakness vulnerability. All users are impacted. This is fixed in version 1.3.21.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass by Primary Weakness in github.com/kongchuanhujiao/server","id":"CVE-2021-21403","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Crash due to malformed relay protocol message","id":"CVE-2021-21404"},"packages":[{"ecosystem":"Go","fixed":["1.3.21"],"introduced":["0"],"last_affected":[],"package":"github.com/kongchuanhujiao/server","purl":null,"source":"GHSA-8wrg-m8vm-5fvj"},{"ecosystem":"Go","fixed":["1.3.21"],"introduced":["0"],"last_affected":[],"package":"github.com/kongchuanhujiao/server","purl":"pkg:golang/github.com/kongchuanhujiao/server","source":"GHSA-8wrg-m8vm-5fvj"}],"prev":{"headline":"Unauthenticated Arbitrary File Access in Jellyfin","id":"CVE-2021-21402"},"products":["server"],"published":"2021-03-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["kongchuanhujiao"]},"summary":"An authentication bypass vulnerability allows attackers to access the server without valid credentials, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2021-21403/"}