# CVE-2021-21403: Authentication Bypass by Primary Weakness in github.com/kongchuanhujiao/server

> An authentication bypass vulnerability allows attackers to access the server without valid credentials, requiring an upgrade to the latest version.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8wrg-m8vm-5fvj

## What is CVE-2021-21403?

CVE-2021-21403 is a high-severity authentication bypass vulnerability in kongchuanhujiao server, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In github.com/kongchuanhujiao/server before version 1.3.21 there is an authentication Bypass by Primary Weakness vulnerability. All users are impacted. This is fixed in version 1.3.21.

Weakness: CWE-287 (Improper Authentication), CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2021-21403?

2 open source packages ship an affected version, including github.com/kongchuanhujiao/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kongchuanhujiao/server` | Go | All versions | 1.3.21 |
| `github.com/kongchuanhujiao/server` | Go | All versions | 1.3.21 |

Products: Kongchuanhujiao Project Kongchuanhujiao.

## How do I fix CVE-2021-21403?

Upgrade github.com/kongchuanhujiao/server to 1.3.21 or later.

## Is CVE-2021-21403 being exploited?

There is no known exploitation of CVE-2021-21403 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21403 and fix it if it is affected.

What it is: CVE-2021-21403 is a high-severity authentication bypass vulnerability in kongchuanhujiao server, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21403 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kongchuanhujiao/server (Go): affected all versions; fixed in 1.3.21
- github.com/kongchuanhujiao/server (Go): affected all versions; fixed in 1.3.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21403/ (Markdown: https://insights.sbomify.com/CVE-2021-21403/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21403
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21403
- OSV: https://osv.dev/vulnerability/CVE-2021-21403

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21403/
Summaries are generated and may contain mistakes; the official description above is the record.
