# CVE-2021-21409: Possible request smuggling in HTTP/2 due missing validation of content-length

> Attackers can perform HTTP request smuggling via Netty's HTTP/2 codec when content-length validation is missing, potentially bypassing security controls.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2021
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-WI10177, CLEANSTART-2026-ZX30626, DEBIAN-CVE-2021-21409, GHSA-f256-j965-7f32, SUSE-SU-2022:1315-1, UBUNTU-CVE-2021-21409

## What is CVE-2021-21409?

CVE-2021-21409 is a medium-severity vulnerability in Debian Debian Linux, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part of 4.1.61.Final.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2021-21409?

6 open source packages ship an affected version, including io.netty:netty, io.netty:netty-codec-http2 and org.jboss.netty:netty. It affects 18 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty-codec-http2` | Maven | From 4.0.0 | 4.1.61.Final |
| `io.netty:netty-codec-http2` | Maven | From 4.0.0 | 4.1.61.Final |
| `org.jboss.netty:netty` | Maven | All versions | None |
| `org.jboss.netty:netty` | Maven | All versions | None |
| `netty` | openSUSE:Leap 15.3 | All versions | 4.1.75-150200.4.9.1 |

Products: Debian Debian Linux, Netapp Oncommand Api Services, Netapp Oncommand Workflow Automation, Netty Netty, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management, Oracle Banking Trade Finance Process Management, Oracle Coherence, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Cloud Native Core Console, Oracle Communications Cloud Native Core Policy, Oracle Communications Design Studio, Oracle Communications Messaging Server, Oracle Helidon, Oracle Jd Edwards Enterpriseone Tools, Oracle Nosql Database, Oracle Primavera Gateway, Quarkus Quarkus.

## How do I fix CVE-2021-21409?

Upgrade to a fixed version.

## Is CVE-2021-21409 being exploited?

There is no known exploitation of CVE-2021-21409 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21409 and fix it if it is affected.

What it is: CVE-2021-21409 is a medium-severity vulnerability in Debian Debian Linux, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21409 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty-codec-http2 (Maven): affected from 4.0.0; fixed in 4.1.61.Final
- io.netty:netty-codec-http2 (Maven): affected from 4.0.0; fixed in 4.1.61.Final
- org.jboss.netty:netty (Maven): affected all versions; no fix listed
- org.jboss.netty:netty (Maven): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21409/ (Markdown: https://insights.sbomify.com/CVE-2021-21409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21409
- OSV: https://osv.dev/vulnerability/CVE-2021-21409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21409/
Summaries are generated and may contain mistakes; the official description above is the record.
