{"answers":{"affected":"2 open source packages ship an affected version, including @thi.ng/egf. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21412 in the wild and no public exploit code.","fix":"Upgrade @thi.ng/egf to 0.4.0 or later.","what":"CVE-2021-21412 is a medium-severity command injection vulnerability in thi-ng egf, published on 30 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21412 and fix it if it is affected.\n\nWhat it is: CVE-2021-21412 is a medium-severity command injection vulnerability in thi-ng egf, published on 30 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21412 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @thi.ng/egf (npm): affected all versions; fixed in 0.4.0\n- @thi.ng/egf (npm): affected all versions; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21412/ (Markdown: https://insights.sbomify.com/CVE-2021-21412/index.md)","id":"CVE-2021-21412","markdown":"https://insights.sbomify.com/CVE-2021-21412/index.md","name":"CVE-2021-21412","record":{"aliases":["GHSA-rj44-gpjc-29r7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"npm egf library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code via crafted GPG-tagged values in the thi.ng/egf npm library when decryption is enabled.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"\\@thi.ng\\/egf","vendor":"\\@thi.ng\\/egf_project"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Potential for arbitrary code execution in npm package @thi.ng/egf `#gpg`-tagged property values (only if `decrypt: true` option is enabled). PR with patch has been submitted and will has been released as of v0.4.0 By default the EGF parse functions do NOT attempt to decrypt values (since GPG only available in non-browser env). However, if GPG encrypted values are used/required: 1. Perform a regex search for `#gpg`-tagged values in the EGF source file/string and check for backtick (\\`) chars in the encrypted value string 2. Replace/remove them or skip parsing if present.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"[thi.ng/egf] Potential arbitrary code execution of `#gpg`-tagged property values","id":"CVE-2021-21412","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Misuse of `Reference` and other transferable APIs may lead to access to nodejs isolate","id":"CVE-2021-21413"},"packages":[{"ecosystem":"npm","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"@thi.ng/egf","purl":null,"source":"GHSA-rj44-gpjc-29r7"},{"ecosystem":"npm","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"@thi.ng/egf","purl":"pkg:npm/%40thi.ng/egf","source":"GHSA-rj44-gpjc-29r7"}],"prev":{"headline":"Incorrect authorization in OAuth2-Proxy","id":"CVE-2021-21411"},"products":["egf"],"published":"2021-03-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["thi-ng"]},"summary":"Attackers can execute arbitrary code via crafted GPG-tagged values in the thi.ng/egf npm library when decryption is enabled.","url":"https://insights.sbomify.com/CVE-2021-21412/"}