# CVE-2021-21412: [thi.ng/egf] Potential arbitrary code execution of `#gpg`-tagged property values

> Attackers can execute arbitrary code via crafted GPG-tagged values in the thi.ng/egf npm library when decryption is enabled.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rj44-gpjc-29r7

## What is CVE-2021-21412?

CVE-2021-21412 is a medium-severity command injection vulnerability in thi-ng egf, published on 30 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Potential for arbitrary code execution in npm package @thi.ng/egf `#gpg`-tagged property values (only if `decrypt: true` option is enabled). PR with patch has been submitted and will has been released as of v0.4.0 By default the EGF parse functions do NOT attempt to decrypt values (since GPG only available in non-browser env). However, if GPG encrypted values are used/required: 1. Perform a regex search for `#gpg`-tagged values in the EGF source file/string and check for backtick (\`) chars in the encrypted value string 2. Replace/remove them or skip parsing if present.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-21412?

2 open source packages ship an affected version, including @thi.ng/egf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@thi.ng/egf` | npm | All versions | 0.4.0 |
| `@thi.ng/egf` | npm | All versions | 0.4.0 |

Products: \@Thi.ng\/Egf Project \@Thi.ng\/Egf.

## How do I fix CVE-2021-21412?

Upgrade @thi.ng/egf to 0.4.0 or later.

## Is CVE-2021-21412 being exploited?

There is no known exploitation of CVE-2021-21412 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21412 and fix it if it is affected.

What it is: CVE-2021-21412 is a medium-severity command injection vulnerability in thi-ng egf, published on 30 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21412 in the wild and no public exploit code.

Affected packages and fixed versions:
- @thi.ng/egf (npm): affected all versions; fixed in 0.4.0
- @thi.ng/egf (npm): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21412/ (Markdown: https://insights.sbomify.com/CVE-2021-21412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21412
- OSV: https://osv.dev/vulnerability/CVE-2021-21412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21412/
Summaries are generated and may contain mistakes; the official description above is the record.
