{"answers":{"affected":"2 open source packages ship an affected version, including @prisma/sdk. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21414 in the wild and no public exploit code.","fix":"Upgrade @prisma/sdk to 2.20.0 or later.","what":"CVE-2021-21414 is a high-severity command injection vulnerability in prisma, published on 29 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21414 and fix it if it is affected.\n\nWhat it is: CVE-2021-21414 is a high-severity command injection vulnerability in prisma, published on 29 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21414 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @prisma/sdk (npm): affected all versions; fixed in 2.20.0\n- @prisma/sdk (npm): affected all versions; fixed in 2.20.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21414/ (Markdown: https://insights.sbomify.com/CVE-2021-21414/index.md)","id":"CVE-2021-21414","markdown":"https://insights.sbomify.com/CVE-2021-21414/index.md","name":"CVE-2021-21414","record":{"aliases":["GHSA-pxcc-hj8w-fmm7"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Prisma SDK","requires_auth":"high_privilege","summary":"Command injection in Prisma SDK allows remote code execution if the getPackedPackage function is called with untrusted input.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prisma","vendor":"prisma"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Prisma is an open source ORM for Node.js \u0026 TypeScript. As of today, we are not aware of any Prisma users or external consumers of the `@prisma/sdk` package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the `getPackedPackage` function and this function is not advertised and only used for tests \u0026 building our CLI, no malicious code was found after checking our codebase.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection vulnerability in @prisma/sdk in getPackedPackage function","id":"CVE-2021-21414","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Visual Studio Code Prisma Extension Remote Code Execution Vulnerability","id":"CVE-2021-21415"},"packages":[{"ecosystem":"npm","fixed":["2.20.0"],"introduced":["0"],"last_affected":[],"package":"@prisma/sdk","purl":null,"source":"GHSA-pxcc-hj8w-fmm7"},{"ecosystem":"npm","fixed":["2.20.0"],"introduced":["0"],"last_affected":[],"package":"@prisma/sdk","purl":"pkg:npm/%40prisma/sdk","source":"GHSA-pxcc-hj8w-fmm7"}],"prev":{"headline":"Misuse of `Reference` and other transferable APIs may lead to access to nodejs isolate","id":"CVE-2021-21413"},"products":["prisma"],"published":"2021-04-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["prisma"]},"summary":"Command injection in Prisma SDK allows remote code execution if the getPackedPackage function is called with untrusted input.","url":"https://insights.sbomify.com/CVE-2021-21414/"}