# CVE-2021-21414: Command injection vulnerability in @prisma/sdk in getPackedPackage function

> Command injection in Prisma SDK allows remote code execution if the getPackedPackage function is called with untrusted input.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pxcc-hj8w-fmm7

## What is CVE-2021-21414?

CVE-2021-21414 is a high-severity command injection vulnerability in prisma, published on 29 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the `@prisma/sdk` package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the `getPackedPackage` function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-21414?

2 open source packages ship an affected version, including @prisma/sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@prisma/sdk` | npm | All versions | 2.20.0 |
| `@prisma/sdk` | npm | All versions | 2.20.0 |

Products: Prisma Prisma.

## How do I fix CVE-2021-21414?

Upgrade @prisma/sdk to 2.20.0 or later.

## Is CVE-2021-21414 being exploited?

There is no known exploitation of CVE-2021-21414 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21414 and fix it if it is affected.

What it is: CVE-2021-21414 is a high-severity command injection vulnerability in prisma, published on 29 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21414 in the wild and no public exploit code.

Affected packages and fixed versions:
- @prisma/sdk (npm): affected all versions; fixed in 2.20.0
- @prisma/sdk (npm): affected all versions; fixed in 2.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21414/ (Markdown: https://insights.sbomify.com/CVE-2021-21414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21414
- OSV: https://osv.dev/vulnerability/CVE-2021-21414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21414/
Summaries are generated and may contain mistakes; the official description above is the record.
