{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21415 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-21415 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-21415 is a high-severity code injection vulnerability in prisma language-tools, published on 29 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21415 and fix it if it is affected.\n\nWhat it is: CVE-2021-21415 is a high-severity code injection vulnerability in prisma language-tools, published on 29 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21415 in the wild and no public exploit code.\n\nAffected product: prisma language-tools. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21415/ (Markdown: https://insights.sbomify.com/CVE-2021-21415/index.md)","id":"CVE-2021-21415","markdown":"https://insights.sbomify.com/CVE-2021-21415/index.md","name":"CVE-2021-21415","record":{"aliases":["GHSA-4rf9-43m7-x828"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"VS Code extension","requires_auth":"none","summary":"Attackers can execute arbitrary code via malicious settings in VS Code projects using the Prisma extension, requiring user interaction to open the project.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"language-tools","vendor":"prisma"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Prisma VS Code a VSCode extension for Prisma schema files. This is a Remote Code Execution Vulnerability that affects all versions of the Prisma VS Code extension older than 2.20.0. If a custom binary path for the Prisma format binary is set in VS Code Settings, for example by downloading a project that has a .vscode/settings.json file that sets a value for \"prismaFmtBinPath\". That custom binary is executed when auto-formatting is triggered by VS Code or when validation checks are triggered after each keypress on a *.prisma file. Fixed in versions 2.20.0 and 20.0.27. As a workaround users can either edit or delete the `.vscode/settings.json` file or check if the binary is malicious and delete it.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Visual Studio Code Prisma Extension Remote Code Execution Vulnerability","id":"CVE-2021-21415","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Potential sensitive information disclosed in error reports","id":"CVE-2021-21416"},"packages":[],"prev":{"headline":"Command injection vulnerability in @prisma/sdk in getPackedPackage function","id":"CVE-2021-21414"},"products":["language-tools"],"published":"2021-04-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["prisma"]},"summary":"Attackers can execute arbitrary code via malicious settings in VS Code projects using the Prisma extension, requiring user interaction to open the project.","url":"https://insights.sbomify.com/CVE-2021-21415/"}