# CVE-2021-21415: Visual Studio Code Prisma Extension Remote Code Execution Vulnerability

> Attackers can execute arbitrary code via malicious settings in VS Code projects using the Prisma extension, requiring user interaction to open the project.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4rf9-43m7-x828

## What is CVE-2021-21415?

CVE-2021-21415 is a high-severity code injection vulnerability in prisma language-tools, published on 29 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Prisma VS Code a VSCode extension for Prisma schema files. This is a Remote Code Execution Vulnerability that affects all versions of the Prisma VS Code extension older than 2.20.0. If a custom binary path for the Prisma format binary is set in VS Code Settings, for example by downloading a project that has a .vscode/settings.json file that sets a value for "prismaFmtBinPath". That custom binary is executed when auto-formatting is triggered by VS Code or when validation checks are triggered after each keypress on a *.prisma file. Fixed in versions 2.20.0 and 20.0.27. As a workaround users can either edit or delete the `.vscode/settings.json` file or check if the binary is malicious and delete it.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-21415?

It affects 1 product.


Products: Prisma Language-Tools.

## How do I fix CVE-2021-21415?

No fix has been published for CVE-2021-21415 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-21415 being exploited?

There is no known exploitation of CVE-2021-21415 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21415 and fix it if it is affected.

What it is: CVE-2021-21415 is a high-severity code injection vulnerability in prisma language-tools, published on 29 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21415 in the wild and no public exploit code.

Affected product: prisma language-tools. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21415/ (Markdown: https://insights.sbomify.com/CVE-2021-21415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21415
- OSV: https://osv.dev/vulnerability/CVE-2021-21415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21415/
Summaries are generated and may contain mistakes; the official description above is the record.
