{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/ps_emailsubscription. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21418 in the wild and no public exploit code.","fix":"Upgrade prestashop/ps_emailsubscription to 2.6.1 or later.","what":"CVE-2021-21418 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_emailsubscription, published on 31 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21418 and fix it if it is affected.\n\nWhat it is: CVE-2021-21418 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_emailsubscription, published on 31 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21418 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/ps_emailsubscription (Packagist): affected all versions; fixed in 2.6.1\n- prestashop/ps_emailsubscription (Packagist): affected all versions; fixed in 2.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21418/ (Markdown: https://insights.sbomify.com/CVE-2021-21418/index.md)","id":"CVE-2021-21418","markdown":"https://insights.sbomify.com/CVE-2021-21418/index.md","name":"CVE-2021-21418","record":{"aliases":["GHSA-vwfx-hh3w-fj99"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop newsletter module","requires_auth":"low_privilege","summary":"An employee can inject JavaScript into the newsletter conditions field, leading to execution in the front office.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ps_emailsubscription","vendor":"prestashop"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ps_emailsubscription is a newsletter subscription module for the PrestaShop platform. An employee can inject javascript in the newsletter condition field that will then be executed on the front office The issue has been fixed in 2.6.1","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential XSS injection in the newsletter conditions field","id":"CVE-2021-21418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Improper Handling of Highly Compressed Data (Data Amplification) and Memory Allocation with Excessive Size Value in eventlet","id":"CVE-2021-21419"},"packages":[{"ecosystem":"Packagist","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_emailsubscription","purl":null,"source":"GHSA-vwfx-hh3w-fj99"},{"ecosystem":"Packagist","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_emailsubscription","purl":"pkg:composer/prestashop/ps_emailsubscription","source":"GHSA-vwfx-hh3w-fj99"}],"prev":{"headline":"Use after free in fluidsynth","id":"CVE-2021-21417"},"products":["ps_emailsubscription"],"published":"2021-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["PrestaShop"]},"summary":"An employee can inject JavaScript into the newsletter conditions field, leading to execution in the front office.","url":"https://insights.sbomify.com/CVE-2021-21418/"}