# CVE-2021-21418: Potential XSS injection in the newsletter conditions field

> An employee can inject JavaScript into the newsletter conditions field, leading to execution in the front office.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vwfx-hh3w-fj99

## What is CVE-2021-21418?

CVE-2021-21418 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_emailsubscription, published on 31 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ps_emailsubscription is a newsletter subscription module for the PrestaShop platform. An employee can inject javascript in the newsletter condition field that will then be executed on the front office The issue has been fixed in 2.6.1

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21418?

2 open source packages ship an affected version, including prestashop/ps_emailsubscription. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/ps_emailsubscription` | Packagist | All versions | 2.6.1 |
| `prestashop/ps_emailsubscription` | Packagist | All versions | 2.6.1 |

Products: Prestashop Ps Emailsubscription.

## How do I fix CVE-2021-21418?

Upgrade prestashop/ps_emailsubscription to 2.6.1 or later.

## Is CVE-2021-21418 being exploited?

There is no known exploitation of CVE-2021-21418 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21418 and fix it if it is affected.

What it is: CVE-2021-21418 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_emailsubscription, published on 31 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21418 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/ps_emailsubscription (Packagist): affected all versions; fixed in 2.6.1
- prestashop/ps_emailsubscription (Packagist): affected all versions; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21418/ (Markdown: https://insights.sbomify.com/CVE-2021-21418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21418
- OSV: https://osv.dev/vulnerability/CVE-2021-21418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21418/
Summaries are generated and may contain mistakes; the official description above is the record.
