{"answers":{"affected":"3 open source packages ship an affected version, including eventlet. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-21419 in the wild and no public exploit code.","fix":"Upgrade eventlet to 0.31.0 or later.","what":"CVE-2021-21419 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 7 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21419 and fix it if it is affected.\n\nWhat it is: CVE-2021-21419 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 7 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21419 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eventlet (PyPI): affected from 0.10; fixed in 0.31.0\n- eventlet (PyPI): affected from 0.10; fixed in 0.31.0\n- eventlet (PyPI): affected from 0.10.0; fixed in 0.31.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21419/ (Markdown: https://insights.sbomify.com/CVE-2021-21419/index.md)","id":"CVE-2021-21419","markdown":"https://insights.sbomify.com/CVE-2021-21419/index.md","name":"CVE-2021-21419","record":{"aliases":["DEBIAN-CVE-2021-21419","GHSA-9p9m-jm8w-94p2","MGASA-2021-0266","PYSEC-2021-12","RHSA-2021:5071","UBUNTU-CVE-2021-21419","USN-4956-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python networking library","requires_auth":"none","summary":"A malicious peer can exhaust memory in the eventlet library by sending large or highly compressed websocket frames, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"eventlet","vendor":"eventlet"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Eventlet is a concurrent networking library for Python. A websocket peer may exhaust memory on Eventlet side by sending very large websocket frames. Malicious peer may exhaust memory on Eventlet side by sending highly compressed data frame. A patch in version 0.31.0 restricts websocket frame to reasonable limits. As a workaround, restricting memory usage via OS limits would help against overall machine exhaustion, but there is no workaround to protect Eventlet process.","ecosystems":["PyPI","Red Hat:openstack:16.1::el8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Handling of Highly Compressed Data (Data Amplification) and Memory Allocation with Excessive Size Value in eventlet","id":"CVE-2021-21419","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2021"},"n_packages":5,"n_references":3,"next":{"headline":"Vulnerability in Stripe for Visual Studio Code \u003c 1.7.3","id":"CVE-2021-21420"},"packages":[{"ecosystem":"PyPI","fixed":["0.31.0"],"introduced":["0.10"],"last_affected":[],"package":"eventlet","purl":null,"source":"GHSA-9p9m-jm8w-94p2"},{"ecosystem":"PyPI","fixed":["0.31.0"],"introduced":["0.10"],"last_affected":[],"package":"eventlet","purl":"pkg:pypi/eventlet","source":"GHSA-9p9m-jm8w-94p2"},{"ecosystem":"PyPI","fixed":["0.31.0"],"introduced":["0.10.0"],"last_affected":[],"package":"eventlet","purl":"pkg:pypi/eventlet","source":"PYSEC-2021-12"},{"ecosystem":"Red Hat:openstack:16.1::el8","fixed":["0:0.25.2-5.el8ost.1"],"introduced":["0"],"last_affected":[],"package":"python-eventlet","purl":"pkg:rpm/redhat/python-eventlet","source":"RHSA-2021:5071"},{"ecosystem":"Red Hat:openstack:16.1::el8","fixed":["0:0.25.2-5.el8ost.1"],"introduced":["0"],"last_affected":[],"package":"python3-eventlet","purl":"pkg:rpm/redhat/python3-eventlet","source":"RHSA-2021:5071"}],"prev":{"headline":"Potential XSS injection in the newsletter conditions field","id":"CVE-2021-21418"},"products":["eventlet"],"published":"2021-05-07","related":[{"cvss_score":6.3,"headline":"Eventlet affected by HTTP request smuggling in unparsed trailers","id":"CVE-2025-58068","kev_date_added":null,"published":"2025-08-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["eventlet"]},"summary":"A malicious peer can exhaust memory in the eventlet library by sending large or highly compressed websocket frames, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2021-21419/"}