{"answers":{"affected":"2 open source packages ship an affected version, including node-etsy-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21421 in the wild and no public exploit code.","fix":"Upgrade node-etsy-client to 0.3.0 or later.","what":"CVE-2021-21421 is a high-severity vulnerability in creharmony node-etsy-client, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21421 and fix it if it is affected.\n\nWhat it is: CVE-2021-21421 is a high-severity vulnerability in creharmony node-etsy-client, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21421 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-etsy-client (npm): affected all versions; fixed in 0.3.0\n- node-etsy-client (npm): affected all versions; fixed in 0.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21421/ (Markdown: https://insights.sbomify.com/CVE-2021-21421/index.md)","id":"CVE-2021-21421","markdown":"https://insights.sbomify.com/CVE-2021-21421/index.md","name":"CVE-2021-21421","record":{"aliases":["GHSA-xw22-wv29-3299"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Etsy API client","requires_auth":"low_privilege","summary":"An attacker can obtain API keys if the application exposes client errors to end users, requiring an upgrade to the library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"node-etsy-client","vendor":"node-etsy-client_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"node-etsy-client is a NodeJs Etsy ReST API Client. Applications that are using node-etsy-client and reporting client error to the end user will offer api key value too This is fixed in node-etsy-client v0.3.0 and later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ApiKey secret could be revelated on network issue","id":"CVE-2021-21421","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"XSS Vulnerability in mongo-express","id":"CVE-2021-21422"},"packages":[{"ecosystem":"npm","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"node-etsy-client","purl":null,"source":"GHSA-xw22-wv29-3299"},{"ecosystem":"npm","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"node-etsy-client","purl":"pkg:npm/node-etsy-client","source":"GHSA-xw22-wv29-3299"}],"prev":{"headline":"Vulnerability in Stripe for Visual Studio Code \u003c 1.7.3","id":"CVE-2021-21420"},"products":["node-etsy-client"],"published":"2021-04-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["creharmony"]},"summary":"An attacker can obtain API keys if the application exposes client errors to end users, requiring an upgrade to the library.","url":"https://insights.sbomify.com/CVE-2021-21421/"}