# CVE-2021-21421: ApiKey secret could be revelated on network issue

> An attacker can obtain API keys if the application exposes client errors to end users, requiring an upgrade to the library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xw22-wv29-3299

## What is CVE-2021-21421?

CVE-2021-21421 is a high-severity vulnerability in creharmony node-etsy-client, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

node-etsy-client is a NodeJs Etsy ReST API Client. Applications that are using node-etsy-client and reporting client error to the end user will offer api key value too This is fixed in node-etsy-client v0.3.0 and later.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-21421?

2 open source packages ship an affected version, including node-etsy-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-etsy-client` | npm | All versions | 0.3.0 |
| `node-etsy-client` | npm | All versions | 0.3.0 |

Products: Node-Etsy-Client Project Node-Etsy-Client.

## How do I fix CVE-2021-21421?

Upgrade node-etsy-client to 0.3.0 or later.

## Is CVE-2021-21421 being exploited?

There is no known exploitation of CVE-2021-21421 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21421 and fix it if it is affected.

What it is: CVE-2021-21421 is a high-severity vulnerability in creharmony node-etsy-client, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21421 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-etsy-client (npm): affected all versions; fixed in 0.3.0
- node-etsy-client (npm): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21421/ (Markdown: https://insights.sbomify.com/CVE-2021-21421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21421
- OSV: https://osv.dev/vulnerability/CVE-2021-21421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21421/
Summaries are generated and may contain mistakes; the official description above is the record.
