{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21425 exists.","fix":"No fix has been published for CVE-2021-21425 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-21425 is a critical missing authorization vulnerability in getgrav grav-plugin-admin, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21425 and fix it if it is affected.\n\nWhat it is: CVE-2021-21425 is a critical missing authorization vulnerability in getgrav grav-plugin-admin, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21425 exists.\n\nAffected product: getgrav grav-plugin-admin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21425/ (Markdown: https://insights.sbomify.com/CVE-2021-21425/index.md)","id":"CVE-2021-21425","markdown":"https://insights.sbomify.com/CVE-2021-21425/index.md","name":"CVE-2021-21425","record":{"aliases":["GHSA-6f53-6qgv-39pj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav Admin Plugin","requires_auth":"none","summary":"Unauthenticated attackers can modify YAML files to execute code or hijack admin accounts in Grav Admin Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav-plugin-admin","vendor":"getgrav"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Grav Admin Plugin is an HTML user interface that provides a way to configure Grav and create and modify pages. In versions 1.10.7 and earlier, an unauthenticated user can execute some methods of administrator controller without needing any credentials. Particular method execution will result in arbitrary YAML file creation or content change of existing YAML files on the system. Successfully exploitation of that vulnerability results in configuration changes, such as general site information change, custom scheduler job definition, etc. Due to the nature of the vulnerability, an adversary can change some part of the webpage, or hijack an administrator account, or execute operating system command under the context of the web-server user. This vulnerability is fixed in version 1.10.8. Blocking access to the `/admin` path from untrusted sources can be applied as a workaround.","ecosystems":[],"exploits":{"exploitdb":1,"first_seen":"2021-03-29","github_poc":5,"max_poc_stars":12,"metasploit":1,"nuclei":0,"refs":[{"date":"2021-06-24T13:06:24Z","kind":"github_poc","ref":"https://github.com/CsEnox/CVE-2021-21425","stars":12,"title":"GravCMS Unauthenticated Arbitrary YAML Write/Update leads to Code Execution (CVE-2021-21425)"},{"date":"2024-11-13T00:30:59Z","kind":"github_poc","ref":"https://github.com/bluetoothStrawberry/cve-2021-21425","stars":2,"title":"working exploit for the old cve-2021-21425 grav cms 1.7.10 vuln"},{"date":"2021-03-29","kind":"metasploit","ref":"exploit/linux/http/gravcms_exec","stars":null,"title":"GravCMS Remote Command Execution"},{"date":"2021-04-21","kind":"exploitdb","ref":"49788","stars":null,"title":"GravCMS 1.10.7 - Unauthenticated Arbitrary File Write (Metasploit)"},{"date":"2022-01-19T17:54:19Z","kind":"github_poc","ref":"https://github.com/grey-master-a/GravCMS_Nmap_Script","stars":0,"title":"It is a nmap script for GravCMS vulnerability (CVE-2021-21425)"},{"date":"2026-01-21T04:45:04Z","kind":"github_poc","ref":"https://github.com/afifudinmtop/CVE-2021-21425","stars":0,"title":null},{"date":"2026-06-23T21:28:06Z","kind":"github_poc","ref":"https://github.com/s1lentf00thold/CVE-2021-21425-RCE","stars":0,"title":null}],"tier":"weaponised"},"has_fix":false,"headline":"Unauthenticated Arbitrary YAML Write/Update leads to Code Execution","id":"CVE-2021-21425","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Fixes a bug in Zend Framework's Stream HTTP Wrapper","id":"CVE-2021-21426"},"packages":[],"prev":{"headline":"Prevent user enumeration using Guard or the new Authenticator-based Security","id":"CVE-2021-21424"},"products":["grav-plugin-admin"],"published":"2021-04-07","related":[{"cvss_score":6.8,"headline":"Grav Admin Plugin vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/config/site` parameter `data[taxonomies]`","id":"CVE-2025-66308","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.5,"headline":"Grav Admin Plugin vulnerable to User Enumeration \u0026 Email Disclosure","id":"CVE-2025-66307","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.2,"headline":"Grav is vulnerable to Cross-Site Scripting (XSS) Reflected endpoint /admin/pages/[page], parameter data[header][content][items], located in the \"Blog Config\" tab","id":"CVE-2025-66309","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.2,"headline":"Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` parameter `data[header][template]` in Advanced Tab","id":"CVE-2025-66310","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.2,"headline":"Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters","id":"CVE-2025-66311","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.2,"headline":"Grav Admin Plugin is vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/accounts/groups/[group]` parameter `data[readableName]`","id":"CVE-2025-66312","kev_date_added":null,"published":"2025-12-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["getgrav"]},"summary":"Unauthenticated attackers can modify YAML files to execute code or hijack admin accounts in Grav Admin Plugin.","url":"https://insights.sbomify.com/CVE-2021-21425/"}