CVE-2021-21426 Fixes a bug in Zend Framework's Stream HTTP Wrapper

Critical 9.8 Published Updated

Unsecured deserialization in Magento LTS allows attackers to execute arbitrary code via the Stream HTTP Wrapper.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-21426?

CVE-2021-21426 is a critical unsafe deserialization vulnerability in OpenMage magento-lts, published on 21 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). In magento-lts versions 19.4.12 and prior and 20.0.8 and prior, there is a vulnerability caused by the unsecured deserialization of an object. A patch in versions 19.4.13 and 20.0.9 was back ported from Zend Framework 3. The vulnerability was assigned CVE-2021-3007 in Zend Framework.

Weakness: CWE-502

Which versions are affected by CVE-2021-21426?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions19.4.13
openmage/magento-lts PackagistAll versions19.4.13
openmage/magento-lts PackagistFrom 20.0.020.0.9
openmage/magento-lts PackagistFrom 20.0.020.0.9

Products include Openmage Magento.

How do I fix CVE-2021-21426?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.13 or 20.0.9.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2021-21426 being exploited?

There is no known exploitation of CVE-2021-21426 in the wild and no public exploit code.

Sources

Also known as GHSA-m496-x567-f98c.

Is CVE-2021-21426 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free