# CVE-2021-21426: Fixes a bug in Zend Framework's Stream HTTP Wrapper

> Unsecured deserialization in Magento LTS allows attackers to execute arbitrary code via the Stream HTTP Wrapper.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m496-x567-f98c

## What is CVE-2021-21426?

CVE-2021-21426 is a critical unsafe deserialization vulnerability in OpenMage magento-lts, published on 21 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). In magento-lts versions 19.4.12 and prior and 20.0.8 and prior, there is a vulnerability caused by the unsecured deserialization of an object. A patch in versions 19.4.13 and 20.0.9 was back ported from Zend Framework 3. The vulnerability was assigned CVE-2021-3007 in Zend Framework.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-21426?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 19.4.13 |
| `openmage/magento-lts` | Packagist | All versions | 19.4.13 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.9 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.9 |

Products: Openmage Magento.

## How do I fix CVE-2021-21426?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.13 or 20.0.9.

## Is CVE-2021-21426 being exploited?

There is no known exploitation of CVE-2021-21426 in the wild and no public exploit code.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)
- [CVE-2020-15244](https://insights.sbomify.com/CVE-2020-15244/): RCE in Magento (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21426 and fix it if it is affected.

What it is: CVE-2021-21426 is a critical unsafe deserialization vulnerability in OpenMage magento-lts, published on 21 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21426 in the wild and no public exploit code.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.13
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.13
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.9
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21426/ (Markdown: https://insights.sbomify.com/CVE-2021-21426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21426
- OSV: https://osv.dev/vulnerability/CVE-2021-21426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21426/
Summaries are generated and may contain mistakes; the official description above is the record.
