CVE-2021-21427 Backport for CVE-2021-21024 Blind SQLi from Magento 2

Critical 9.1 Published Updated

An administrator can exploit a blind SQL injection vulnerability to access restricted resources in Magento LTS.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-21427?

CVE-2021-21427 is a critical SQL injection vulnerability in OpenMage magento-lts, published on 21 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). A vulnerability in magento-lts versions before 19.4.13 and 20.0.9 potentially allows an administrator unauthorized access to restricted resources. This is a backport of CVE-2021-21024. The vulnerability is patched in versions 19.4.13 and 20.0.9.

Weakness: CWE-89

Which versions are affected by CVE-2021-21427?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions19.4.13
openmage/magento-lts PackagistAll versions19.4.13
openmage/magento-lts PackagistFrom 20.0.020.0.9
openmage/magento-lts PackagistFrom 20.0.020.0.9

Products include Openmage Magento.

How do I fix CVE-2021-21427?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.13 or 20.0.9.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2021-21427 being exploited?

There is no known exploitation of CVE-2021-21427 in the wild and no public exploit code.

Sources

Also known as GHSA-fvrf-9428-527m.

Is CVE-2021-21427 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free