# CVE-2021-21430: Creation of Temporary File in Directory with Insecure Permissions in auto-generated Java, Scala code

> Attackers can read or modify insecure temporary files created by auto-generated Java/Scala code during binary uploads or downloads.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-cqxr-xf2w-943w

## What is CVE-2021-21430?

CVE-2021-21430 is a medium-severity vulnerability in OpenAPITools openapi-generator, published on 10 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenAPI Generator allows generation of API client libraries (SDK generation), server stubs, documentation and configuration automatically given an OpenAPI Spec. Using `File.createTempFile` in JDK will result in creating and using insecure temporary files that can leave application and system data vulnerable to attacks. Auto-generated code (Java, Scala) that deals with uploading or downloading binary data through API endpoints will create insecure temporary files during the process. Affected generators: `java` (jersey2, okhttp-gson (default library)), `scala-finch`. The issue has been patched with `Files.createTempFile` and released in the v5.1.0 stable version.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2021-21430?

2 open source packages ship an affected version, including org.openapitools:openapi-generator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openapitools:openapi-generator` | Maven | All versions | 5.1.0 |
| `org.openapitools:openapi-generator` | Maven | All versions | 5.1.0 |

Products: Openapi-Generator Openapi Generator.

## How do I fix CVE-2021-21430?

Upgrade org.openapitools:openapi-generator to 5.1.0 or later.

## Is CVE-2021-21430 being exploited?

There is no known exploitation of CVE-2021-21430 in the wild and no public exploit code.

## Other vulnerabilities in OpenAPITools openapi-generator

- [CVE-2021-21428](https://insights.sbomify.com/CVE-2021-21428/): Creation of Temporary File in Directory with Insecure Permissions in the OpenAPI-Generator online generator (critical 9.3)
- [CVE-2023-27162](https://insights.sbomify.com/CVE-2023-27162/): OpenAPI Generator vulnerable to Server-Side Request Forgery (critical 9.1)
- [CVE-2019-11405](https://insights.sbomify.com/CVE-2019-11405/): OpenAPI Tools OpenAPI Generator uses HTTP in various files (high 8.1)
- [CVE-2021-21429](https://insights.sbomify.com/CVE-2021-21429/): Creation of Temporary File in Directory with Insecure Permissions in the OpenAPI Generator Maven plugin (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21430 and fix it if it is affected.

What it is: CVE-2021-21430 is a medium-severity vulnerability in OpenAPITools openapi-generator, published on 10 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21430 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openapitools:openapi-generator (Maven): affected all versions; fixed in 5.1.0
- org.openapitools:openapi-generator (Maven): affected all versions; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21430/ (Markdown: https://insights.sbomify.com/CVE-2021-21430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21430
- OSV: https://osv.dev/vulnerability/CVE-2021-21430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21430/
Summaries are generated and may contain mistakes; the official description above is the record.
