# CVE-2021-21432: Reject unauthorized access with GitHub PATs

> Attackers can bypass authentication to access secrets via injected credentials in the netrc file within the Vela CI/CD server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8j3f-mhq8-gmh4, GO-2022-0812

## What is CVE-2021-21432?

CVE-2021-21432 is a high-severity missing authorization vulnerability in go-vela server, published on 9 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. An authentication mechanism added in version 0.7.0 enables some malicious user to obtain secrets utilizing the injected credentials within the `~/.netrc` file. Refer to the referenced GitHub Security Advisory for complete details. This is fixed in version 0.7.5.

Weakness: CWE-862 (Missing Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2021-21432?

3 open source packages ship an affected version, including github.com/go-vela/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-vela/server` | Go | From 0.7.0 | 0.7.5 |
| `github.com/go-vela/server` | Go | From 0.7.0 | 0.7.5 |
| `github.com/go-vela/server` | Go | From 0.7.0 | 0.7.5 |

Products: Go-Vela Vela.

## How do I fix CVE-2021-21432?

Upgrade github.com/go-vela/server to 0.7.5 or later.

## Is CVE-2021-21432 being exploited?

There is no known exploitation of CVE-2021-21432 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21432 and fix it if it is affected.

What it is: CVE-2021-21432 is a high-severity missing authorization vulnerability in go-vela server, published on 9 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21432 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-vela/server (Go): affected from 0.7.0; fixed in 0.7.5
- github.com/go-vela/server (Go): affected from 0.7.0; fixed in 0.7.5
- github.com/go-vela/server (Go): affected from 0.7.0; fixed in 0.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21432/ (Markdown: https://insights.sbomify.com/CVE-2021-21432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21432
- OSV: https://osv.dev/vulnerability/CVE-2021-21432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21432/
Summaries are generated and may contain mistakes; the official description above is the record.
