CVE-2021-2144 Privilege escalation in MySQL Server

High 7.2 Published Updated

A high-privileged attacker can compromise the MySQL Server via the parser, leading to full server takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-2144?

CVE-2021-2144 is a high-severity vulnerability in Mariadb Mariadb, published on 22 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Parser). Supported versions that are affected are 5.7.29 and prior and 8.0.19 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in takeover of MySQL Server. CVSS 3.1 Base Score 7.2 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H).

Which versions are affected by CVE-2021-2144?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 6 products.

PackageAffectedFixed in
mariadb BitnamiFrom 5.5.05.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9
mariadb-min BitnamiFrom 5.5.05.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9
mysql-client BitnamiFrom 5.5.05.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9

Products include Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Oracle Mysql.

How do I fix CVE-2021-2144?

Upgrade mariadb to a fixed version for your release line: 5.5.66, 10.1.42, 10.2.28 or 10.3.19.

Is CVE-2021-2144 being exploited?

There is no known exploitation of CVE-2021-2144 in the wild and no public exploit code.

All Mariadb Mariadb vulnerabilities

Sources

Also known as BIT-mariadb-2021-2144, BIT-mariadb-min-2021-2144, BIT-mysql-client-2021-2144, GHSA-m8h9-m594-xwrv, UBUNTU-CVE-2021-2144.

Is CVE-2021-2144 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free