# CVE-2021-2144: Privilege escalation in MySQL Server

> A high-privileged attacker can compromise the MySQL Server via the parser, leading to full server takeover.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2021
- **Updated:** 26 Sep 2024
- **Also known as:** BIT-mariadb-2021-2144, BIT-mariadb-min-2021-2144, BIT-mysql-client-2021-2144, GHSA-m8h9-m594-xwrv, UBUNTU-CVE-2021-2144

## What is CVE-2021-2144?

CVE-2021-2144 is a high-severity vulnerability in Mariadb Mariadb, published on 22 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Parser). Supported versions that are affected are 5.7.29 and prior and 8.0.19 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in takeover of MySQL Server. CVSS 3.1 Base Score 7.2 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H).

## Which versions are affected by CVE-2021-2144?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 5.5.0 | 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9 |
| `mariadb-min` | Bitnami | From 5.5.0 | 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9 |
| `mysql-client` | Bitnami | From 5.5.0 | 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9 |

Products: Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Oracle Mysql.

## How do I fix CVE-2021-2144?

Upgrade mariadb to a fixed version for your release line: 5.5.66, 10.1.42, 10.2.28 or 10.3.19.

## Is CVE-2021-2144 being exploited?

There is no known exploitation of CVE-2021-2144 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-2144 and fix it if it is affected.

What it is: CVE-2021-2144 is a high-severity vulnerability in Mariadb Mariadb, published on 22 Apr 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-2144 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 5.5.0; fixed in 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9
- mariadb-min (Bitnami): affected from 5.5.0; fixed in 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9
- mysql-client (Bitnami): affected from 5.5.0; fixed in 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-2144/ (Markdown: https://insights.sbomify.com/CVE-2021-2144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-2144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-2144
- OSV: https://osv.dev/vulnerability/CVE-2021-2144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-2144/
Summaries are generated and may contain mistakes; the official description above is the record.
