{"answers":{"affected":"2 open source packages ship an affected version, including github.com/apache/servicecomb-service-center. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21501 in the wild and no public exploit code.","fix":"Upgrade github.com/apache/servicecomb-service-center to 2.0.0 or later.","what":"CVE-2021-21501 is a high-severity path traversal vulnerability in Apache ServiceComb, published on 10 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21501 and fix it if it is affected.\n\nWhat it is: CVE-2021-21501 is a high-severity path traversal vulnerability in Apache ServiceComb, published on 10 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21501 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.0.0\n- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21501/ (Markdown: https://insights.sbomify.com/CVE-2021-21501/index.md)","id":"CVE-2021-21501","markdown":"https://insights.sbomify.com/CVE-2021-21501/index.md","name":"CVE-2021-21501","record":{"aliases":["GHSA-x6jv-5vfg-gm7x"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"ServiceComb ServiceCenter","requires_auth":"none","summary":"An attacker can read arbitrary files from the server due to improper configuration in ServiceComb ServiceCenter.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"servicecomb","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Improper configuration will cause ServiceComb ServiceCenter Directory Traversal problem in ServcieCenter 1.x.x versions and fixed in 2.0.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ServiceComb ServiceCenter Directory Traversal","id":"CVE-2021-21501","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Auth bypass in PowerScale OneFS","id":"CVE-2021-21502"},"packages":[{"ecosystem":"Go","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":null,"source":"GHSA-x6jv-5vfg-gm7x"},{"ecosystem":"Go","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":"pkg:golang/github.com/apache/servicecomb-service-center","source":"GHSA-x6jv-5vfg-gm7x"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2021-21495"},"products":["Apache ServiceComb"],"published":"2021-08-10","related":[{"cvss_score":7.6,"headline":"Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API","id":"CVE-2023-44313","kev_date_added":null,"published":"2024-01-31"},{"cvss_score":5.8,"headline":"Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server","id":"CVE-2023-44312","kev_date_added":null,"published":"2024-01-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"An attacker can read arbitrary files from the server due to improper configuration in ServiceComb ServiceCenter.","url":"https://insights.sbomify.com/CVE-2021-21501/"}