# CVE-2021-21501: ServiceComb ServiceCenter Directory Traversal

> An attacker can read arbitrary files from the server due to improper configuration in ServiceComb ServiceCenter.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x6jv-5vfg-gm7x

## What is CVE-2021-21501?

CVE-2021-21501 is a high-severity path traversal vulnerability in Apache ServiceComb, published on 10 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper configuration will cause ServiceComb ServiceCenter Directory Traversal problem in ServcieCenter 1.x.x versions and fixed in 2.0.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-21501?

2 open source packages ship an affected version, including github.com/apache/servicecomb-service-center. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/servicecomb-service-center` | Go | All versions | 2.0.0 |
| `github.com/apache/servicecomb-service-center` | Go | All versions | 2.0.0 |

Products: Apache Servicecomb.

## How do I fix CVE-2021-21501?

Upgrade github.com/apache/servicecomb-service-center to 2.0.0 or later.

## Is CVE-2021-21501 being exploited?

There is no known exploitation of CVE-2021-21501 in the wild and no public exploit code.

## Other vulnerabilities in Apache ServiceComb

- [CVE-2023-44313](https://insights.sbomify.com/CVE-2023-44313/): Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API (high 7.6)
- [CVE-2023-44312](https://insights.sbomify.com/CVE-2023-44312/): Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21501 and fix it if it is affected.

What it is: CVE-2021-21501 is a high-severity path traversal vulnerability in Apache ServiceComb, published on 10 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21501 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.0.0
- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21501/ (Markdown: https://insights.sbomify.com/CVE-2021-21501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21501
- OSV: https://osv.dev/vulnerability/CVE-2021-21501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21501/
Summaries are generated and may contain mistakes; the official description above is the record.
