# CVE-2021-21609: Missing permission check for paths with specific prefix in Jenkins

> Attackers without Overall/Read permission can access restricted URLs due to incorrect path matching, bypassing authorization controls in Jenkins.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-jenkins-2021-21609, GHSA-4625-q52w-39cx

## What is CVE-2021-21609?

CVE-2021-21609 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 13 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not correctly match requested URLs to the list of always accessible paths, allowing attackers without Overall/Read permission to access some URLs as if they did have Overall/Read permission.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-21609?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.263.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.263.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.264 | 2.275 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.264 | 2.275 |
| `jenkins` | Bitnami | All versions | 2.274.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2021-21609?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.263.2 or 2.275.

## Is CVE-2021-21609 being exploited?

There is no known exploitation of CVE-2021-21609 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21609 and fix it if it is affected.

What it is: CVE-2021-21609 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 13 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21609 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.263.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.263.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.264; fixed in 2.275
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.264; fixed in 2.275
- jenkins (Bitnami): affected all versions; fixed in 2.274.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21609/ (Markdown: https://insights.sbomify.com/CVE-2021-21609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21609
- OSV: https://osv.dev/vulnerability/CVE-2021-21609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21609/
Summaries are generated and may contain mistakes; the official description above is the record.
