CVE-2021-21610 Reflected XSS vulnerability in Jenkins markup formatter preview

Medium 6.1 Published Updated

Reflected XSS in Jenkins allows attackers to execute scripts if the markup formatter permits unsafe elements, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-21610?

CVE-2021-21610 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 13 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not implement any restrictions for the URL rendering a formatted preview of markup passed as a query parameter, resulting in a reflected cross-site scripting (XSS) vulnerability if the configured markup formatter does not prohibit unsafe elements (JavaScript) in markup.

Weakness: CWE-79

Which versions are affected by CVE-2021-21610?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.263.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.263.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.2642.275
org.jenkins-ci.main:jenkins-core MavenFrom 2.2642.275
jenkins BitnamiAll versions2.274.1

Products include Jenkins Jenkins.

How do I fix CVE-2021-21610?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.263.2 or 2.275.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-21610 being exploited?

There is no known exploitation of CVE-2021-21610 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as BIT-jenkins-2021-21610, GHSA-7qf3-c2q8-69m3.

Is CVE-2021-21610 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free