{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:bumblebee. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21614 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:bumblebee to 4.1.6 or later.","what":"CVE-2021-21614 is a medium-severity vulnerability in Jenkins Bumblebee HP ALM Plugin, published on 13 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21614 and fix it if it is affected.\n\nWhat it is: CVE-2021-21614 is a medium-severity vulnerability in Jenkins Bumblebee HP ALM Plugin, published on 13 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:bumblebee (Maven): affected all versions; fixed in 4.1.6\n- org.jenkins-ci.plugins:bumblebee (Maven): affected all versions; fixed in 4.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21614/ (Markdown: https://insights.sbomify.com/CVE-2021-21614/index.md)","id":"CVE-2021-21614","markdown":"https://insights.sbomify.com/CVE-2021-21614/index.md","name":"CVE-2021-21614","record":{"aliases":["GHSA-8v72-qr3h-c6rv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Jenkins HP ALM Plugin","requires_auth":"low_privilege","summary":"Attackers with Jenkins controller file system access can read unencrypted credentials stored by the HP ALM Plugin.","user_interaction":"not_required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"bumblebee_hp_alm","vendor":"jenkins"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Jenkins Bumblebee HP ALM Plugin 4.1.5 and earlier stores credentials unencrypted in its global configuration file on the Jenkins controller where they can be viewed by users with access to the Jenkins controller file system.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Credentials stored in plain text by Jenkins Bumblebee HP ALM Plugin","id":"CVE-2021-21614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"hardcoded_credentials","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Time-of-check Time-of-use (TOCTOU) Race Condition in Jenkins","id":"CVE-2021-21615"},"packages":[{"ecosystem":"Maven","fixed":["4.1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:bumblebee","purl":null,"source":"GHSA-8v72-qr3h-c6rv"},{"ecosystem":"Maven","fixed":["4.1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:bumblebee","purl":"pkg:maven/org.jenkins-ci.plugins/bumblebee","source":"GHSA-8v72-qr3h-c6rv"}],"prev":{"headline":"XSS vulnerability in Jenkins TICS Plugin","id":"CVE-2021-21613"},"products":["Jenkins Bumblebee HP ALM Plugin"],"published":"2021-01-13","related":[{"cvss_score":6.5,"headline":"Jenkins Bumblebee HP ALM Plugin unconditionally disabled SSL/TLS certificate validation","id":"CVE-2019-10444","kev_date_added":null,"published":"2019-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with Jenkins controller file system access can read unencrypted credentials stored by the HP ALM Plugin.","url":"https://insights.sbomify.com/CVE-2021-21614/"}