# CVE-2021-21614: Credentials stored in plain text by Jenkins Bumblebee HP ALM Plugin

> Attackers with Jenkins controller file system access can read unencrypted credentials stored by the HP ALM Plugin.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8v72-qr3h-c6rv

## What is CVE-2021-21614?

CVE-2021-21614 is a medium-severity vulnerability in Jenkins Bumblebee HP ALM Plugin, published on 13 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins Bumblebee HP ALM Plugin 4.1.5 and earlier stores credentials unencrypted in its global configuration file on the Jenkins controller where they can be viewed by users with access to the Jenkins controller file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2021-21614?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:bumblebee. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:bumblebee` | Maven | All versions | 4.1.6 |
| `org.jenkins-ci.plugins:bumblebee` | Maven | All versions | 4.1.6 |

Products: Jenkins Bumblebee Hp Alm.

## How do I fix CVE-2021-21614?

Upgrade org.jenkins-ci.plugins:bumblebee to 4.1.6 or later.

## Is CVE-2021-21614 being exploited?

There is no known exploitation of CVE-2021-21614 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Bumblebee HP ALM Plugin

- [CVE-2019-10444](https://insights.sbomify.com/CVE-2019-10444/): Jenkins Bumblebee HP ALM Plugin unconditionally disabled SSL/TLS certificate validation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21614 and fix it if it is affected.

What it is: CVE-2021-21614 is a medium-severity vulnerability in Jenkins Bumblebee HP ALM Plugin, published on 13 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21614 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:bumblebee (Maven): affected all versions; fixed in 4.1.6
- org.jenkins-ci.plugins:bumblebee (Maven): affected all versions; fixed in 4.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21614/ (Markdown: https://insights.sbomify.com/CVE-2021-21614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21614
- OSV: https://osv.dev/vulnerability/CVE-2021-21614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21614/
Summaries are generated and may contain mistakes; the official description above is the record.
