{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:configurationslicing. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21617 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:configurationslicing to 1.52 or later.","what":"CVE-2021-21617 is a high-severity vulnerability in Jenkins Configuration Slicing Plugin, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21617 and fix it if it is affected.\n\nWhat it is: CVE-2021-21617 is a high-severity vulnerability in Jenkins Configuration Slicing Plugin, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21617 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:configurationslicing (Maven): affected all versions; fixed in 1.52\n- org.jenkins-ci.plugins:configurationslicing (Maven): affected all versions; fixed in 1.52\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21617/ (Markdown: https://insights.sbomify.com/CVE-2021-21617/index.md)","id":"CVE-2021-21617","markdown":"https://insights.sbomify.com/CVE-2021-21617/index.md","name":"CVE-2021-21617","record":{"aliases":["GHSA-42mm-x828-56c7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"none","summary":"Attackers can trick users into applying unauthorized slice configurations in the Jenkins Configuration Slicing Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"configuration_slicing","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Configuration Slicing Plugin 1.51 and earlier allows attackers to apply different slice configurations.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins Configuration Slicing Plugin","id":"CVE-2021-21617","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Stored XSS vulnerability in Jenkins Repository Connector Plugin","id":"CVE-2021-21618"},"packages":[{"ecosystem":"Maven","fixed":["1.52"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:configurationslicing","purl":null,"source":"GHSA-42mm-x828-56c7"},{"ecosystem":"Maven","fixed":["1.52"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:configurationslicing","purl":"pkg:maven/org.jenkins-ci.plugins/configurationslicing","source":"GHSA-42mm-x828-56c7"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins Active Choices Plugin","id":"CVE-2021-21616"},"products":["Jenkins Configuration Slicing Plugin"],"published":"2021-02-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can trick users into applying unauthorized slice configurations in the Jenkins Configuration Slicing Plugin.","url":"https://insights.sbomify.com/CVE-2021-21617/"}