# CVE-2021-21618: Stored XSS vulnerability in Jenkins Repository Connector Plugin

> Stored XSS in Jenkins Repository Connector Plugin allows attackers with configure permissions to execute scripts in past builds.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hg2w-3c4j-jjwm

## What is CVE-2021-21618?

CVE-2021-21618 is a medium-severity cross-site scripting vulnerability in Jenkins Repository Connector Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Repository Connector Plugin 2.0.2 and earlier does not escape parameter names and descriptions for past builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21618?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:repository-connector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:repository-connector` | Maven | All versions | 2.0.3 |
| `org.jenkins-ci.plugins:repository-connector` | Maven | All versions | 2.0.3 |

Products: Jenkins Repository Connector.

## How do I fix CVE-2021-21618?

Upgrade org.jenkins-ci.plugins:repository-connector to 2.0.3 or later.

## Is CVE-2021-21618 being exploited?

There is no known exploitation of CVE-2021-21618 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Repository Connector Plugin

- [CVE-2019-1003038](https://insights.sbomify.com/CVE-2019-1003038/): Jenkins Repository Connector Plugin has insufficiently protected credentials (high 7.8)
- [CVE-2022-34195](https://insights.sbomify.com/CVE-2022-34195/): Cross-site Scripting in Jenkins Repository Connector Plugin (medium 5.4)
- [CVE-2020-2149](https://insights.sbomify.com/CVE-2020-2149/): Credentials transmitted in plain text by Repository Connector Plugin (medium 5.3)
- [CVE-2022-36903](https://insights.sbomify.com/CVE-2022-36903/): Jenkins Repository Connector Plugin allows attackers with Overall/Read permission to enumerate credentials IDs (medium 4.3)
- [CVE-2022-36904](https://insights.sbomify.com/CVE-2022-36904/): Jenkins Repository Connector Plugin does not perform a permission check in a method implementing form validation (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21618 and fix it if it is affected.

What it is: CVE-2021-21618 is a medium-severity cross-site scripting vulnerability in Jenkins Repository Connector Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21618 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:repository-connector (Maven): affected all versions; fixed in 2.0.3
- org.jenkins-ci.plugins:repository-connector (Maven): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21618/ (Markdown: https://insights.sbomify.com/CVE-2021-21618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21618
- OSV: https://osv.dev/vulnerability/CVE-2021-21618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21618/
Summaries are generated and may contain mistakes; the official description above is the record.
