{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:claim. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21619 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:claim to 2.18.2 or later.","what":"CVE-2021-21619 is a medium-severity cross-site scripting vulnerability in Jenkins Claim Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21619 and fix it if it is affected.\n\nWhat it is: CVE-2021-21619 is a medium-severity cross-site scripting vulnerability in Jenkins Claim Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21619 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:claim (Maven): affected all versions; fixed in 2.18.2\n- org.jenkins-ci.plugins:claim (Maven): affected all versions; fixed in 2.18.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21619/ (Markdown: https://insights.sbomify.com/CVE-2021-21619/index.md)","id":"CVE-2021-21619","markdown":"https://insights.sbomify.com/CVE-2021-21619/index.md","name":"CVE-2021-21619","record":{"aliases":["GHSA-48hr-jg4p-w4p4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Claim Plugin","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via user display names in the Jenkins Claim Plugin, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"claim","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Claim Plugin 2.18.1 and earlier does not escape the user display name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers who are able to control the display names of Jenkins users, either via the security realm, or directly inside Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS vulnerability in Jenkins Claim Plugin","id":"CVE-2021-21619","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-Site Request Forgery in the Jenkins Claim plugin","id":"CVE-2021-21620"},"packages":[{"ecosystem":"Maven","fixed":["2.18.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:claim","purl":null,"source":"GHSA-48hr-jg4p-w4p4"},{"ecosystem":"Maven","fixed":["2.18.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:claim","purl":"pkg:maven/org.jenkins-ci.plugins/claim","source":"GHSA-48hr-jg4p-w4p4"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins Repository Connector Plugin","id":"CVE-2021-21618"},"products":["Jenkins Claim Plugin"],"published":"2021-02-24","related":[{"cvss_score":4.3,"headline":"Cross-Site Request Forgery in the Jenkins Claim plugin","id":"CVE-2021-21620","kev_date_added":null,"published":"2021-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can inject malicious scripts via user display names in the Jenkins Claim Plugin, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2021-21619/"}